Board logo

标题: [分享] Zend Opcache安装脚本 [打印本页]

作者: ngbanyan    时间: 2014-3-13 14:11     标题: Zend Opcache安装脚本

Zend Opcache 已经集成在了PHP 5.5里面,编译安装PHP5.5的时候加上--enable-opcache就行了。但也支持低版本的 PHP 5.2.*, 5.3.*, 5.4.*,未来会取消对5.2的支持,下面是我在PHP 5.4下的安装脚本:

下载:
zendopcache_ins.rar (805 Bytes)


安装步骤:
1.解压安装包,将放置于root根目录下
2.
  1. sh ./zendopcache_ins.sh
复制代码




说明:
1.可选你现用的PHP版本,对应到相应extensions目录
2.使用最新版本,不保证所有PHP版本都能兼容
3.查看zendopcache是否已开启


附件: zendopcache_ins.rar (2014-3-13 14:11, 805 Bytes) / 下载次数 134
http://wdlinux.cn/bbs/attachment.php?aid=4289&k=84aab7429ab7d5259df3f34a0fb6ac20&t=1675778692&sid=7naf7P
作者: kgmxsady    时间: 2014-3-14 08:50

看看!!!!!
作者: 111111    时间: 2014-3-27 15:54

看看 。。谢谢
作者: 夏筱羽    时间: 2014-3-29 02:54

Please Input 1,2: 2
取回中 http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm
正在准备…             ##################################################
        从 /etc/yum.repos.d/rpmforge.repo 安装的档案 rpmforge-release-0.5.3-1.el6.rf.x86_64 与来自套件 rpmforge-release-0.5.2-2.el6.rf.x86_64 的档案产生冲突

这个是????
作者: webjin    时间: 2014-3-31 13:15

要重新编译吗?
作者: hgl1312    时间: 2014-6-27 14:15

我来看看 我来看看看看
作者: jskj222    时间: 2014-7-1 19:45

支持看看哦
作者: jskj222    时间: 2014-7-6 23:57

支持不错!!!!
作者: junlee    时间: 2014-7-7 00:00

下载来看看啊
作者: junlee    时间: 2014-7-7 00:03

到底行不行啊?
作者: chentao4669    时间: 2014-11-22 18:06

看看行不行
作者: 暮山    时间: 2014-11-24 02:23

感谢分享!!!!!!!!!!
作者: zdbscn    时间: 2014-12-14 18:46

要重新编译吗?
作者: zyojl    时间: 2015-1-4 11:48

【表情】不行啊!@
作者: hk568    时间: 2015-2-2 20:56

不保证所有PHP版本都能兼容
作者: 养猪能手    时间: 2015-2-7 16:43

这个要学习看看
作者: 3g210    时间: 2015-4-4 22:03

回复 1# ngbanyan

为什么照你的方法安装了Zend OPcache 会出现502错误啊?详情如下:
服务器为PHP 5.4.37,mysql-5.5.36,Apache,共有多个站点都没有出现502错误。最近安装了Zend OPcache,其中有一个网站的pnp页出现出现502错误,其他网站没有此问题,如果把Apache切换为nginx就立即没有502错误了,不知何故求彻底解决?
现通过测试进一步发现,如果把/www/wdlinux/apache_php-5.4.37/etc/php.ini文件中的[Zend Opcache]代码(详见如下红色部分)全部删除,再切换为Apache网站的502错误就没有了,并且查看/www/wdlinux/etc/php.ini的内容自动变成与/www/wdlinux/apache_php-5.4.37/etc/php.ini的一样了。

虽然删除了[Zend Opcache]代码可以解决502错误问题,但是原来配置的Zend Opcache应该说就没有效了吧,所以还需大神给出彻底解决方案。



[Zend Opcache]
zend_extension= /www/wdlinux/php/lib/php/extensions/no-debug-non-zts-20100525/opcache.so
opcache.memory_consumption=128
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=4000
opcache.force_restart_timeout=180
opcache.revalidate_freq=60
opcache.fast_shutdown=1
opcache.enable_cli=1
作者: 孙柄晨    时间: 2015-4-27 13:24

感谢分享!!!!!!!!!!
作者: 孙柄晨    时间: 2015-4-27 13:25

感谢分享!!!!!!!!!!
作者: 孙柄晨    时间: 2015-5-14 22:38

感谢分享!!!!!!!!!!
作者: my1281617143    时间: 2015-5-20 22:50

按教程装了以后,没启动成功?
作者: zzsttok    时间: 2015-6-20 21:41

来看看 我来看看看看
作者: 2004203075    时间: 2015-9-22 13:36

注意:安装过memcache的朋友要先停止memcache

service memcached stop
复制代码
作者: xuweidiy    时间: 2015-10-27 23:16

不错,支持,。
作者: chnspy    时间: 2015-11-1 22:12

不保证所有PHP版本都能兼容,试试看啦
作者: lincchow    时间: 2016-3-17 17:57

我靠 老是要金币
作者: xiezehua    时间: 2016-4-9 01:42

感谢分享!!!!!!!!!!
作者: freenessfish    时间: 2016-5-27 15:46

安装内容?
作者: hzshopping    时间: 2016-6-2 20:30

好东西要大家一起分享啊
作者: skyyw    时间: 2016-6-4 15:48

看看 。。谢谢
作者: songguowei    时间: 2016-7-22 21:54

没金币啊 没金币啊 没金币啊 没金币啊 没金币啊 没金币啊 没金币啊 没金币啊 没金币啊 没金币啊
作者: kitly    时间: 2016-10-14 23:59

感谢分享!!
作者: shazig    时间: 2016-11-28 04:59

不保证所有PHP版本都能兼容
作者: shazig    时间: 2017-1-31 04:34

OpcacheOpcache
作者: yangyiyan    时间: 2017-2-17 00:20

回复 1# ngbanyan


   xiexie....
作者: 冰韩    时间: 2017-2-19 20:23

我金币又不足了
作者: music9394    时间: 2017-2-20 17:39

刚好需要
刚好需要
刚好需要
刚好需要
作者: dingxuanhua    时间: 2017-8-4 19:27

正好需要,看看吧,谢谢了
作者: pengbangying    时间: 2017-11-11 22:47

支持一下哦。楼主厉害啊
作者: sunset415    时间: 2017-12-14 15:39

不保证所有PHP版本都能兼容
作者: 蓝兵    时间: 2018-11-27 13:04

感谢分享,升级试一下




欢迎光临 WDlinux官方论坛 (http://wdlinux.cn/bbs/) Powered by Discuz! 7.2