Board logo

标题: [求助] 用了半年多的lanmp突然502或504错误,但若切换成lamp或lnmp均为正常,求助! [打印本页]

作者: danranyixiao    时间: 2014-5-26 21:26     标题: 用了半年多的lanmp突然502或504错误,但若切换成lamp或lnmp均为正常,求助!

本帖最后由 danranyixiao 于 2014-5-26 22:37 编辑

求助!!本人用了半年多的lanmp双web引擎突然出现502或504错误,若切换成lamp或lnmp却马上变正常,错误页面显示为:502 Bad Gateway   nginx/1.0.15,有时会显示为 504 Gateway Time-out

我的网站程序用的是Discuz X3.1 utf8版,还下了个Emlog程序来测试,也是同样的问题,这样证明啦不是程序的原因。。我网站的每日独立IP在300-500左右,浏览量也不是很大,之前运行一直正常稳定,突然昨天就一下子不能用啦,太奇怪啦。。

目前在lnamp状态下,只有静态html页面可以正常打开。网站前台和后台管理页面均显示502或504错误,我已经百度搜索和wdcp搜索过相关的问题答案,但还是没有解决我的问题,因此在这里发帖急切求助大家!

本人已经试过但未凑效的失败修复办法有:
1、www/wdlinux/etc/中php-fpm.conf:max_children 改成30,request_terminate_timeout由0s改成30s (调整后重启web仍无效)
2、将php-fpm的处理方式改成apache模式:<value name=”style”>apache-like</value> (无效)
3、eaccelerator配置项放在Zend Optimizer配置之前   (检查过源文件就是OK的,不用我修改,无效)
4、修改/usr/local/php/etc/php.ini 将max_execution_time 改为300  (修改过,无效后又改成原来的180)

本人想尝试但不知道怎么操作的修复办法(我是菜鸟,别见笑哈):
1、查看 php-cgi进程 、 FastCGI进程 是否已经启动运行  (未操作,我是菜鸟,不知道从哪里看php-cgi进程是否在运行),若是未启动和运行,那我该怎么启动它呢?请不吝赐教。。

2、调整nginx.conf的相关设置。。(这文件是www/wdlinux/nginx-1.0.15/conf这个目录里面的那个吗?
这个目录里是有个nginx.conf文件,但查找搜索整个文件发现以下几个参数文件里根本搜不到:fastcgi_connect_timeout 、fastcgi_send_timeout 、fastcgi_read_timeout、fastcgi_buffer_size 、fastcgi_buffers、fastcgi_busy_buffers_size 、fastcgi_temp_file_write_size
以上几个参数在我的nginx.conf文件里根本没有,怎么办?需要我自己直接添加到这文件里吗?


我是服务器端端菜鸟,自己比较擅长的领域是:平面PS设计、网页前端设计、Discuz二次开发、淘宝网店运营, 所有热心帮助我解决这个502/504问题的朋友,我都可以在我擅长的领域 无偿免费帮助你,以答谢你对我的帮助!。。。希望好心人看到能帮帮我,本人定当感激不尽!!

下面是我的系统配置信息:

系统名称:WDlinux Control Panel (简称wdCP)
当前版本: wdcp_v2.5.10(20140213)
操作系统:Linux 2.6.18-238.5.1.el5xen
硬盘60G  已经使用15G
CPU参数:1个2核 32位
CPU型号: Intel(R) Xeon(R) CPU E5620 @ 2.40GHz
selinux设置状态:关闭           Memcached缓存服务:未安装       SEO网址伪静态:未使用
运行时间:216天9小时49分                     

内存使用:总:2048M    平时最高使用1100M左右
服务器系统及 PHP :  Linux / PHP v5.2.17p1
  服务器 MySQL 版本:5.1.63        当前数据库尺寸 :14.05 MB

360截图20140526202512343.png
2014-5-26 21:34
   
14052621346bb7e65d9e3662d8.png
2014-5-26 22:16


图片附件: 360截图20140526202512343.png (2014-5-26 21:34, 8.98 KB) / 下载次数 2262
http://wdlinux.cn/bbs/attachment.php?aid=4529&k=8dd1102dd8b28c04f7c96660360a1fc4&t=1664724226&sid=ggufNO



图片附件: 14052621346bb7e65d9e3662d8.png (2014-5-26 22:16, 8.22 KB) / 下载次数 2157
http://wdlinux.cn/bbs/attachment.php?aid=4531&k=a2e5ad2abf92900801393fad0023c8a4&t=1664724226&sid=ggufNO


作者: danranyixiao    时间: 2014-5-26 21:37

本帖最后由 danranyixiao 于 2014-5-26 22:32 编辑

已经百度搜索和wdcp搜索过相关的问题答案,但还是没有解决我的问题,实在是没办法啦,因此在这里发帖急切求助大家!!

我自己比较擅长的领域是:平面PS设计、网页前端设计、Discuz二次开发、淘宝网店运营, 所有热心帮助我解决这个502/504 问题的朋友,我都可以在以上我擅长的几个领域 无偿免费帮助你,以答谢你对我的帮助!坐等高手和好心人帮助!!
|

作者: danranyixiao    时间: 2014-5-30 10:39

没人回复我,我自己来顶一下。。求援助,求帮忙。。
作者: 江家小子    时间: 2014-6-20 17:26

现在解决了吗?怎么解决的?我也出现这问题,刚装好就不能用
作者: shazig    时间: 2014-6-25 08:35

php.ini中的zend信息,放到最后
作者: fh466@126.com    时间: 2014-7-1 19:37

问题解决了吗?
作者: cbynd    时间: 2015-2-6 09:06

没有的参数可以自行增加的
作者: sendsky    时间: 2015-2-16 14:29

你去看看你的防火墙是不是增加了很多拒绝的端口? 如果是 把防火墙关掉就好了..不知道新版搞什么鬼
作者: onlyyjf    时间: 2018-3-4 17:53

解决了吗 求方法
作者: ddlinux    时间: 2018-9-4 09:07

style 在哪里




欢迎光临 WDlinux官方论坛 (http://wdlinux.cn/bbs/) Powered by Discuz! 7.2